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What is VMD ?
Visual Molecular Dynamics (VMD) is a molecular visualization 
program for displaying, animating, and analyzing large 
biomolecular systems using 3-D graphics and built-in scripting.

Features:

● Distributed free of charge, and includes source code.
● Available for MacOS, Unix, or Windows.
● Very fast, written in C++. 

Supports Multi-core CPUs, GPUs, and CUDA.
● Tcl and Python scripting.
● Supports over 60 molecular file formats and data types.
● Publication quality image rendering.





Getting VMD
Download: 
https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD

Citing VMD
Humphrey, W., Dalke, A. and Schulten, K., ”VMD - Visual Molecular Dynamics”,
J. Molec. Graphics, 1996, vol. 14, pp. 33-38.

Also see: http://www.ks.uiuc.edu/Research/vmd/allversions/cite.html

VMD is Copyright © 
1995-2016 Theoretical 
and Computational 
Biophysics Group and at 
the University of Illinois 
at Urbana-Champaign.

https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD
http://www.ks.uiuc.edu/Research/vmd/allversions/cite.html


Overview of VMD related topics
● Basic techniques

○ Molecules and 

representations.

○ 3D navigation.

○ Drawing methods.

○ Materials and coloring.

● Working with trajectories.

● Creating animations and movies.

● Scripting and automation.

● Rendering high quality images.

● Data analysis.

● Visualization of volumetric data.

● Running VMD in HPC environment.



Starting VMD

OpenGL graphics 
window

Main control
window

Terminal
window
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Extensions



Loading a new molecule
1. Load for a 

New Molecule.
2. Determine type

Automatically.
3. Select file

speptide.pdb
4. Click Load.
5. Close the 

dialog.



Loaded molecule

Loaded
molecul
e

Loading  a molecule
Short Peptide:
● 146 atoms;
● 19 residues;



Trajectory animation controls

List of moleculesMain control window
ID - molecule
        number.
T - “Top” stat. 
A - Active.
D - Drawn.
F  - Fixed.
# of Atoms.
# of Frames.
Volumetric data.

“Red” means inactive



Working with a single molecule

Graphical 
Representations
window



More options

Representations
● Atom selection
● Drawing method
● Coloring method
● Material 

Molecule selector.

List of 
Representations.

Atom selection.

Drawing method,
Coloring scheme,
Material controls.

Drawing method
parameters.

A molecule can have 
multiple 
representations.



Setting up your work space

Distribute the windows 
to maximize work space.



Setting up work space

Colours control
window



Colour control Items and 
Objects

Colour 
SelectorCategories

Colour
Editor

Floating dialog.
Stays until closed.



Changing view

Representation
of the molecule,
“Licorice”.

3D Axes



Changing view

+ <Cmnd>

Scrolling or Mouse wheel 
for Zooming

“Rotate” mode



Changing view

“R” - rotate
“T” - translate
“S” - scale
“C” - center
“=” - reset view

Changing view does not
affect actual atomic 
positions. Only changes 
the view point.



Drawing methods

VDW:
Van-der-Waals spheres.
Roughly represent 
Actual size of the atoms.



Lines:
Structure, atoms.
Very lightweight.
Default.

Licorice:
Structure, atoms.
Minimalistic.
Looks better.

CPK:
Structure, atoms.
Relative atom sizes.
Demanding.
Often too cluttered.

VDW:
Structure, atoms.
Realistic volume.
Too ugly.
Cluttered.

Quick Surf:
Volume.
Clean.

Atomistic Drawing Methods



Drawing methods

NewCartoon:
Secondary structure 
based method.
Highlights structural motifs.
Removes atomistic details.

Secondary Structure coloring.

Coil

Coil

Coil

alpha-Helix

Turn



Peptide bonds and peptides

● 21 amino acids for proteins;
● Peptide: 2 to 50 amino acids.
● Protein: > 50 amino acids in 

the chain.
● Long chains form 3D motifs, 

called secondary structure.
● Backbone: [C-C-N]n.
● Most common: alpha-helices 

and beta-sheets.



Ribbons:
Backbone 
orientation 
information

Tube:
Smoothed 
backbone.
Looks much 
cleaner.

Trace:
Peptide 
backbone
information.

NewRibbons:
Cleaner new
version.

Cartoon:
Backbone with
Secondary motif
assignments.

NewCartoon:
Cleaner new
version.

Secondary Structure based Drawing Methods



Display modes

VDW drawing method hides 
secondary structure well.

Note that atoms at farther 
distance  look smaller. 

It is due to Perspective 
screen projection mode.



Screen Projection

Perspective:
● Adds 3D perspective;
● Looks better on 

illustrations.
● Distorts size perception.

Orthographic:
● Parallel projection;
● Same size at different 

distances.
● Better for structural 

analysis.



Depth Cueing

Depth Cueing:

● Improves 3D depth 
perception;

● Makes the model look 
dull.

● Could be useful for final 
rendering.



Rendermode

Rendermode GLSL:
Hardware accelerated 
mode.

● Faster;
● Better looking;
● Needs a GPU video card.
● Much better for 

transparent materials.



Display modes

● Perspective projection
● Depth Cueing ON
● Rendermode Normal

● Orthographic projection
● Depth Cueing OFF
● Rendermode GLSL

Same point of view, but axes look very different.



VMD image workflow
● Start with a Molecule – molecular data from the input file.
● Create Graphical Representations of the molecule.
● Representations are defined by:

○ Selection of the atoms – logical expression.
○ Drawing method – determines the way atoms are shown.
○ Material – determines the appearance of the drawing. 

● Combination of the visual output of all these Graphical 
Representations forms the final result.

● Multiple molecules can be used in one scene, if needed.



Test case: Illustration of GFP structure
Green fluorescent protein (GFP) glows green when exposed 
to blue or UV light (1EMA).
● Create a publication quality illustration of the GFP 

molecule.
● Demonstrate the secondary structure of the molecule 

critical for its fluorescent properties.
● Show it Chromophore center responsible for light 

production.
● Provide information on the protein structure and volume.





Clean Start

1. Reset View
2. Drawing method: Lines
3. Thickness: 1

Note the new 
orientation.



Getting GFP (1EMA) model

1. Extensions → Data → PDB Database Query.
2. PDB Code – 1EMA.
3. Download to local PDB file.



Loading the 1EMA model

● File → New Molecule…
“1ema.pdb”



Working on an illustration

“Lines” is not a good 
representation for large 
protein molecules.



Working on an illustration

● Drawing method: NewCartoon

Secondary Structure 
based representation.



Working on 
an illustration

● Explore the Protein → Side View

Beta-barrel 
scaffold.



Working on an illustration

Central 
Alpha-Helix.

● Explore the Protein → “Down the Barrel” View.



Working on an illustration

● Move the Axes to “Upper Left”.



Working on 
an illustration

1. Create new representation: Licorice
2. Colored by Red color.

Axes are here 
now.



Selections
Tab Current selection

Input buttons
Single word 
predefined 
selections

List of values 
for a selected 
keyword

List of 
data fields, 
keywords



Working on 
an illustration

1. Highlighting the Chromophore.
2. Residues 65, 66, and 67
3. Selection: “residue 64 65 66”.

Point of 
interest



Working on 
an illustration

Make it more visible
● Bond Radius: 0.3 → 0.4
● Sphere Resolution: 12 → 17
● Bond Resolution: 12 → 17



Working on 
an illustration

Make it more visible:
● Material: 

Opaque → EdgyShiny



Working on an illustration

The Beta-Barrel interferes with the Chromophore visibility.
● NewCartoon Material → Transparent.

There is a break in the 
backbone.



Working on an illustration

To fill the break in the backbone
● Create a New Representation: Licorice
● Bond radius: 0.3 → 0.1 



Working on an illustration

● Use Residues 61-65 to fill the gap.
● Representation selection: 

“residue 61 to 65 and not sidechain”.

Strained Alpha-Helix



Working on an illustration

Make it pretty and communicate more information:
● NewCrartoon coloring: Name → Secondary Structure.

Beta-Sheets

Alpha-Helix



Working on 
an illustration

● New Representation: QuickSurf over the entire molecule.
Adding structural realism.

Indicator of 
the actual 
Volume

● Material: GlassBubble.
● Coloring by Secondary Structure.



Working on 
an illustration

Could NewRibbons be better for the main backbone representation?

May be NOT…



Working on 
an illustration

Back the the Transparent NewCartoon representation.

● Let us Render it: File → Render…



Working on 
an illustration

Renderer to use:
● VMD Window snapshot (fast), or
● Internal Tachyon (high quality).



Render dialog

● Internal and External renderers.
● External renderers require additional software.
● Internal (included) options are normally enough.



Working on 
an illustration

Tachyon Render:
Smooth and High Quality.



Done.
● WDV, Scale: 1.0 → 0.5
● Coloring: Element
● Material: EdgyShiny
● Selection: “residue 65 to 67 and not carbon”

Hetero-Atoms 
on the 
Chromophore

New Representation to make Chromophore punchier. 



Save the Work● File → Save Visualization State…



Working with MD Trajectories
● Looking for rare events.
● Validation and Quality control – look for obvious problems.
● Getting visual insight into behaviour:

○ Hypothesis generation;
○ Automatic detection;
○ New possible methods of analysis.

● Facilitate collaboration and communication.
● Education and Outreach.
● Helps with Funding and Grants.



Working with MD Trajectories
● MD Trajectories are typically have two parts

○ Topology – constant part
■ Atom types, bonds, force field, etc.

○ Configurations – atomic coordinates at time steps
■ AKA frames, snapshots.
■ 100-1000s more per trajectory (many).

● Gromacs: GRO + XTC
● NAMD / CHARMM: PSF + DCD
● Multi-frame PDB or XYZ files are also possible 

(contain both).



Working with MD Trajectories
The workflow
● Animate the trajectory in a simple representation.

○ Look for the events of interest.
● Change the representations and selections

to show the found events more clearly;
● Select several “better” frames of the event to use as 

illustrations in static publications and presentations.
● Generate animation videos of the event using a fraction of the 

trajectory for live presentations and demos.



Working with MD Trajectories
Case Study: DLPC lipid bilayer simulation
● System contains 

○ 2369 DLPC lipid molecules.
○ 2305 water molecules.
○ 9603 atoms total.

● The trajectory contains about 1000 snapshots.
● The simulation demonstrates a pore formation event.

Bennett et al. 2014, Atomistic Simulations of Pore Formation and Closure in Lipid 
Bilayers. Biophys J. 106(1) 210-219.



Working on MD trajectory

● Start with a fresh setup.
● File → New Molecule…
● Load a file with topology: DLPC-bilayer.gro



Working on MD trajectory

For the loaded DLPC-bilayer.gro
● Load the coordinate file: DLPC-bilayer.xtc



Working on MD trajectory

● The trajectory is loaded.
● Drawing method: Lines
● Line thickness: 4
● Rewind the trajectory to start.

● 9603 atoms
● 1002 frames

Note the 
orientation.

This is our
Top View



Working on MD trajectory

● Rotate the system to find the best view.

This is our
Side View



Working on MD trajectory

● Rotate again 
● This is our best view of the bilayer.

This is our
Front View



Working on MD trajectory

● Browsing the trajectory frames → frame 160.
● Frames are uncorrelated → motion is jerky.

Front View

Switch to 
Trajectory 
tab.



Working on MD trajectory

● Frame 160
● Smooth the motion by averaging over 5 frames.

Lipid molecules 
are more 
straight now.

Front View

Smoothing
Window 
Size → 5

Smoothing
Artifacts



Working on MD trajectory

● Frame 258
● Remove Water (solven) for clarity
● Selection: “not water”.

Front View



Working on MD trajectoryFront View

Add 1 image on 
both Y-sides.

● Frame 521
● Improve bilayer perception by adding periodic images.
● Representations → Trajectory Tab.



Working on MD trajectory

● Frame 951
● Keep browsing the trajectory for an interesting event.

Front View

Observing
distortion in 
lipid structure



Working on MD trajectory

● Frame 964
● Add water to make Pore Formation more clear.
● Create Representation → VDW

Front View

● Selection → “water and not hydrogen”.



Working on MD trajectory

● Frame 964
● Examine the Top View
● Look for the new Pores.
● The bulk of the water hides the Event.

Poorly visible
Pores.Top View



Working on MD trajectory

● Frame 964
● Back to the Front View
● Remove the bulk of water above and below the bilayer
● Selection → 

“water and not hydrogen and (z > 16 and z < 41)”

Water in 
Pores only.

Front View



Working on MD trajectory
Highlighted 
Pores.

Top View

● Frame 964
● Examine the Top View again.
● The Pores are much more visible now.
● Visible water molecules are limited to Pores (mostly).



Working on MD trajectory

● Frame 102
● Back to the Front View.
● Rewind the trajectory →  Selection does not work.

Water molecules are 
outside the range.

Front View



Working on MD trajectory

● Frame 103
● Switch to the Trajectory Tab.
● Update Selection Every Frame → ON.

No Stray Water 
molecules 

Front View

Too much 
bulk water 
on this side.



Working on MD trajectory

● Frame 739
● Improve bulk water filtering:

Selection → “... (z > 20 and z < 40)”

All water is in 
the Pores.

Front View



Working on MD trajectory

● Frame 791
● Noticed that water motion was not smoothed.
● Trajectory Smoothing Window Size → 5.
● Smoothing is set for each Representation separately.

For water, 
smoothing is not 
very important. 

Front View



Working on MD trajectory

● Frame 829
● Keep looking for the “best” view of the Event.
● This is a good candidate.

Clear
water 
channel

Front View

Stable lipid 
structure



Working on MD trajectory

● Frame 829
● Examine the Top View.
● The Pore only occupies a fraction of the total system depth.
● Lipids behind the Pore may interfere with the Pore perception.

Top View



Working on MD trajectory

● Frame 829
● Remove lipid molecules in front of and behind the Pores.
● Lipid Representation Selection →

“not water and (x > 24 and x < 35)”.

● Water is mostly limited the this region →  no need to cut.

Top View



Working on MD trajectory

● Frame 829
● Back to the Front View.
● Very clear visualization of the bilayer with the pores.
● The downside → lower density of lipid molecules (not critical).

Front View



Working on MD trajectory

● Frame 829
● The best view is found.
● Make the lipid layer look prettier. 
● Representation → Shiny Licorice.

Front View



Working on MD trajectory

● Frame 100
● Rewind the trajectory and check for problems.
● Healthy bilayer at the beginning….

Single Carbon atoms are 
from partially cut molecules.

Front View



Working on MD trajectoryFront View

● Frame 450
● Keep going…
● Water starts to break through the bilayer at this point.
● Lipid molecules show less ordering.



Working on MD trajectoryFront View

● Frame 700
● Keep watching…
● Water channels are well defined at the point.
● Lipid structures have not been fully formed yet.



Working on MD trajectoryFront View

● Frame 950
● The transformation is complete.
● Well defined water channels.
● Well defined lipid structures.



Working on MD trajectory

● Frame 950
● Compare with how a single simulation cell looks.
● Adding periodic cells, in this case, 

○ improves visual perception.
○ helps with detecting the event.

Front View



Working on MD trajectory

● Frame 950
● Render images.
● Use Tachyon.

Front View



Working on MD trajectory

● Rendered image is good.
● With many atoms and small molecules 

the improvement is somewhat limited.



Working on MD trajectory

● Frame 115
● Trying something else…
● Lipid representation → QuickSurf / Transparent.
● This gives sense of the molecular volumes.
● Hints on vibrational and thermal molecular motion.

Front View



Working on MD trajectoryFront View

● Frame 115
● Trying something else…
● Water representation → QuickSurf / EdgyShiny.
● Make water representation consistent with the lipids.



Working on MD trajectoryFront View

● Frame 462
● Trying something else…
● Not necessarily an improvement scientifically.
● Looks very good and adds a significant Wow factor.



Working on MD trajectoryFront View

● Frame 598
● Trying something else…
● Pore forming shows biological smooth fluidity.



Working on MD trajectoryFront View

● Frame 793
● Trying something else…
● Keep going…



Working on MD trajectoryFront View

● Frame 968
● Trying something else…
● This is the best representation of the Pore.



All Done

● Frame 968
● The final rendering by Tachyon.



Making a Movie

● Extensions → Visualization → Movie Maker



Making a Movie

● Extensions → Visualization → Movie Maker



Tool Single 
Structre

MD 
Trajectory

QC 
Orbitals

Molecular 
Builder

High 
Performance

Open 
source

VMD Yes Yes No No Yes No
ChimeraX Yes Limited No No Limited No
PyMOL Yes Limited No No No Yes/No
VTX Yes Yes No No Yes Yes
Avogadro Yes No No Yes No Yes
Gabedit Yes No Yes Yes No Yes
Molekel Yes No Yes No No Mixed
Jmol Yes No Limited No No Yes

Comparing VMD to other options



Comparing VMD to other options
VMD:
● The dominant MD trajectory analysis tool for ~30 years
● Powerful scripting via Tcl/Python, and plug-ins.
● Powerful built-in analysis functions.
● Can handle massive trajectories and large systems.
● Cross-platform: Mac, Linux, Windows.
● Free to use.

Competitors:
● VTX: New. Can render massive trajectories. Weak on analysis
● OVITO: Powerful. More for the material science.



Pre-release beta VMD 2.0.0b1

● Released on 2026-02-26.
● Interface has been redesigned.

○ The Main and Graphics floaters are combined.
○ New Icon toolbar.
○ Python 3.x support.

● Documentation is still for VMD 1.9.3.
● If you now VMD you can use the new one.
● Last stable release: VMD 1.9.3

○ 2016-12-01
● Updated to VMD 1.9.4a in 2023.



VMD resources
● VMD Home: http://www.ks.uiuc.edu/Research/vmd/
● FAQ: 

http://www.ks.uiuc.edu/Research/vmd/allversions/vmd_faq.html
● VMD Documentation:

https://www.ks.uiuc.edu/Research/vmd/current/docs.html

● VMD on Compute Canada:
https://docs.computecanada.ca/wiki/VMD

Data sources:
● PDB Data Bank: https://www.wwpdb.org
● Nucleic Acids Data Bank: http://ndbserver.rutgers.edu

http://www.ks.uiuc.edu/Research/vmd/
http://www.ks.uiuc.edu/Research/vmd/allversions/vmd_faq.html
https://www.ks.uiuc.edu/Research/vmd/current/docs.html
https://docs.computecanada.ca/wiki/VMD
https://www.wwpdb.org
http://ndbserver.rutgers.edu


Thank you!


